Opened 8 years ago

Closed 7 years ago

#13569 closed defect (fixed)

SimpleAES has bad chars in comments

Reported by: Adam Peller Owned by: Tom Trenka
Priority: low Milestone: 1.8
Component: Dojox Version: 1.6.1
Keywords: Cc: Javier Pedemonte, ben hockey
Blocked By: Blocking:

Description

For some reason, this only seems to upset the build on Linux, but it looks like there are a few comments which aren't valid UTF-8, e.g.

http://bugs.dojotoolkit.org/browser/dojo/dojox/trunk/encoding/crypto/SimpleAES.js#L117

Encoding changed in [23144] but I'm not sure it was right before either?

Change History (6)

comment:1 Changed 8 years ago by Adam Peller

Owner: changed from Adam Peller to Tom Trenka

comment:2 Changed 8 years ago by Adam Peller

Milestone: tbd1.7

can potentially break the build. marking for 1.7

comment:3 Changed 8 years ago by ben hockey

feel free to change it. i certainly didn't intentionally introduced these.

comment:4 Changed 8 years ago by Ed Siok

I saw this bug in action while performing a build using the IBM J9 VM JDK (with Java 1.5.0). I could not recreate in a regular Java 1.5 JDK or a Java 1.6 JDK. In case anybody else ever runs into this, I'm adding the Error I found. The generic error was a sun.io.MalformedInputException?

13-Sep-2011 10:44:19	     [exec] release:  Copying: ../../dojo/../dijit to: ../../release/2888/dijit
13-Sep-2011 10:44:26	     [exec] release:  Copying: ../../dojo/../dojox to: ../../release/2888/dojox
13-Sep-2011 10:44:31	     [exec] org.mozilla.javascript.WrappedException: Wrapped sun.io.MalformedInputException
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.Context.throwAsScriptRuntimeEx(Context.java:1654)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:175)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.NativeJavaMethod.call(NativeJavaMethod.java:243)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.optimizer.OptRuntime.callProp0(OptRuntime.java:119)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c3._c7(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c3.call(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.optimizer.OptRuntime.call1(OptRuntime.java:66)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c3._c6(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c3.call(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.optimizer.OptRuntime.callN(OptRuntime.java:86)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c3._c3(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c3.call(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.optimizer.OptRuntime.callN(OptRuntime.java:86)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c1._c4(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c1.call(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.optimizer.OptRuntime.callName(OptRuntime.java:97)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c1._c3(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c1.call(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.optimizer.OptRuntime.call0(OptRuntime.java:57)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c1._c0(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c1.call(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.ContextFactory.doTopCall(ContextFactory.java:401)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.ScriptRuntime.doTopCall(ScriptRuntime.java:3003)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c1.call(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.gen.c1.exec(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.tools.shell.Main.evaluateScript(Main.java:526)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.tools.shell.Main.processFileSecure(Main.java:448)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.tools.shell.Main.processFile(Main.java:414)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.tools.shell.Main.processSource(Main.java:405)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.tools.shell.Main.processFiles(Main.java:179)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.tools.shell.Main$IProxy.run(Main.java:100)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.Context.call(Context.java:499)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.ContextFactory.call(ContextFactory.java:511)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.tools.shell.Main.exec(Main.java:162)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.tools.shell.Main.main(Main.java:140)
13-Sep-2011 10:44:31	     [exec] Caused by: sun.io.MalformedInputException
13-Sep-2011 10:44:31	     [exec]         at sun.io.ByteToCharUTF8.convert(ByteToCharUTF8.java:294)
13-Sep-2011 10:44:31	     [exec]         at sun.nio.cs.StreamDecoder$ConverterSD.convertInto(StreamDecoder.java:316)
13-Sep-2011 10:44:31	     [exec]         at sun.nio.cs.StreamDecoder$ConverterSD.implRead(StreamDecoder.java:366)
13-Sep-2011 10:44:31	     [exec]         at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:252)
13-Sep-2011 10:44:31	     [exec]         at java.io.InputStreamReader.read(InputStreamReader.java:212)
13-Sep-2011 10:44:31	     [exec]         at java.io.BufferedReader.fill(BufferedReader.java:157)
13-Sep-2011 10:44:31	     [exec]         at java.io.BufferedReader.readLine(BufferedReader.java:320)
13-Sep-2011 10:44:31	     [exec]         at java.io.BufferedReader.readLine(BufferedReader.java:383)
13-Sep-2011 10:44:31	     [exec]         at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
13-Sep-2011 10:44:31	     [exec]         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
13-Sep-2011 10:44:31	     [exec]         at java.lang.reflect.Method.invoke(Method.java:618)
13-Sep-2011 10:44:31	     [exec]         at org.mozilla.javascript.MemberBox.invoke(MemberBox.java:160)
13-Sep-2011 10:44:31	     [exec]         ... 33 more

comment:5 Changed 7 years ago by Tom Trenka

Priority: highlow
Status: newassigned

comment:6 Changed 7 years ago by Tom Trenka

Resolution: fixed
Status: assignedclosed

In [27877]:

Remove bad comment chars. Fixes #13569 !strict

Note: See TracTickets for help on using tickets.