Opened 8 years ago

Closed 8 years ago

#13562 closed defect (fixed)

Hard to tell which radio/checkbox has focus in high contrast mode

Reported by: Katie Vance Owned by: Katie Vance
Priority: high Milestone: 1.7
Component: Accessibility Version: 1.6.1
Keywords: high contrast Cc: Becky Gibson
Blocked By: Blocking:

Description

When using FF you cannot tell which radio/checkbox has focus in high contrast mode.

Attachments (1)

13562.patch (475 bytes) - added by Katie Vance 8 years ago.
Add a dotted border around the label

Download all attachments as: .zip

Change History (6)

comment:1 Changed 8 years ago by Katie Vance

Cc: Becky Gibson added

comment:2 Changed 8 years ago by bill

dijit_a11y rules should go into dijit.css not individual theme files (unless there's some exceptional circumstance). You can use !important if needed, although I don't think it's needed in this case

But also, it's hard to believe that outline:... doesn't work on FF, it's even broken on FF5?

Changed 8 years ago by Katie Vance

Attachment: 13562.patch added

Add a dotted border around the label

comment:3 Changed 8 years ago by Katie Vance

I tested on FF5 and still didn't work. I've appended a new patch with changes only to digit.css. I had to use !important to remove the outline. If you don't remove the outline it shows up as a double border in IE.

Last edited 8 years ago by bill (previous) (diff)

comment:4 Changed 8 years ago by bill

Milestone: 1.7
Summary: Hard to tell whcih radio/checkbox has focus in hgih contrast modeHard to tell which radio/checkbox has focus in high contrast mode

OK thanks, I guess outlines just don't appear in high contrast mode on FF (not sure if that's a bug or by design), I'll check in your change.

comment:5 Changed 8 years ago by bill

Resolution: fixed
Status: newclosed

In [26047]:

For checkboxes or radio buttons in high contrast mode, use border rather than outline to indicate focus (outline does not work in FF). Patch from Katie (IBM, CCLA), thanks! Fixes #13562 !strict.

Note: See TracTickets for help on using tickets.