Opened 8 years ago

Closed 8 years ago

#13555 closed defect (fixed)

Fix Module Path Regression in deviceTheme in Mobile Gallery

Reported by: Ming Zhe Huang Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.7.0b1
Keywords: mobile-gallery Cc: Chris Mitchell
Blocked By: Blocking:

Description

This is a recent regression. Previously when specifying the package name of a theme file, "." is used as separator. However, now "/" is used as separator. So the deviceTheme in mobile gallery does NOT work, and there will be an HTTP 404 error during loading.

The fix is very simple. Just replace "." with "/" in the main HTML page. Please see the attached fix.

Sorry I have to put the fix here, since there's no better component to file against.

Chris, would you please help to check in the patch if necessary? Thanks.

Attachments (1)

mobileGallery-2011-08-02.patch (687 bytes) - added by Ming Zhe Huang 8 years ago.
Proposed patch

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Ming Zhe Huang

Proposed patch

comment:1 Changed 8 years ago by ykami

(In [25979]) Refs #13555 !strict. dojo.moduleUrl was changed to require.toUrl with #25876, and this changed the package name delimiter from '.' to '/'. To keep the original spec, convert '.' to '/' internally. Now both delimiters are allowed.

comment:2 Changed 8 years ago by ykami

Oops, "#25876" was wrong. I should have written [25886].

comment:3 Changed 8 years ago by ykami

Well, I didn't know [25886] had such a side-effect. I fixed deviceTheme.js to allow both '.' and '/' since '.' delimiter was external spec, and people may have already been using it. Hopefully your patch is no longer necessary. Please have a try.

comment:4 Changed 8 years ago by ykami

Milestone: tbd1.7
Resolution: fixed
Status: newclosed

Confirmed with Archer.

Note: See TracTickets for help on using tickets.