Opened 8 years ago

Closed 7 years ago

#13553 closed defect (wontfix)

Several PNG files for the Dojox Gantt Chart widget are miscapitalized in gantt.css file

Reported by: Roberto Olivares Owned by: dante
Priority: high Milestone: tbd
Component: DojoX Widgets Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

The Gantt chart widget documentation at http://dojotoolkit.org/reference-guide/dojox/gantt.html says to include the following CSS file in HTML (with baseurl replaced with the location of the Dojo distribution): <link type="text/css" rel="stylesheet" href="{baseUrl}/dojox/gantt/resources/gantt.css">

However, doing so breaks a few Gantt toolbar icons and generates the following errors because those files are miscapitalized:

dojox/resources/images/zoomIn.png - Failed to load resource: the server responded with a status of 404 (Not Found)
dojox/resources/images/zoomOut.png - Failed to load resource: the server responded with a status of 404 (Not Found)
dojox/resources/images/zoomInTime.png - Failed to load resource: the server responded with a status of 404 (Not Found)
dojox/resources/images/zoomOutTime.png - Failed to load resource: the server responded with a status of 404 (Not Found)

These errors also occur in the test page included in the Gantt chart directory: http://svn.dojotoolkit.org/src/dojox/trunk/gantt/tests/test_Gantt.html

And they are caused by lack of capitalization in a few filenames. The fix is to simply rename the PNG files that give these errors to match the capitalization in the CSS file.

Change History (2)

comment:1 Changed 8 years ago by Roberto Olivares

Fix is probably just to rename the files as follows:

dojox/resources/images/zoomin.png --> zoomIn.png
dojox/resources/images/zoomout.png --> zoomOut.png
dojox/resources/images/zoomintime.png --> zoomInTime.png
dojox/resources/images/zoomouttime.png --> zoomOutTime.png
Last edited 8 years ago by Roberto Olivares (previous) (diff)

comment:2 Changed 7 years ago by Tom Trenka

Resolution: wontfix
Status: newclosed

Apparently this is no longer being actively worked on. Closing as wontfix.

Note: See TracTickets for help on using tickets.