Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13542 closed defect (fixed)

Chang dojox/grid/* to baseless and module return value

Reported by: evan Owned by: Evan
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.7.0b1
Keywords: grid, baseless, module, return, value Cc:
Blocked By: Blocking:

Description


Change History (12)

comment:1 Changed 8 years ago by evan

In ([25941]) Refs #13542 !strict change to baseless and module return value for DataGrid? and TreeGrid?

comment:2 Changed 8 years ago by evan

In ([25977]) Refs #13542 !strict change to baseless and module return value for all EDG files

comment:3 Changed 8 years ago by evan

In ([25994]) Refs #13542 !strict using html.* rather than dojo.*

comment:4 Changed 8 years ago by evan

In [26113]:

Refs #13542 fix a regression due baseless change by avoiding overwriting html variable by mistake.

comment:5 Changed 8 years ago by evan

In [26186]:

Refs #13542 !strict add missed piece for module return value changes

comment:6 Changed 8 years ago by evan

Owner: changed from evan to Evan

Got the reason why always not receiving ticket notes.

comment:7 Changed 8 years ago by Evan

In [26210]:

Fixes #13690 based on the patch from Elvis(IBM, CCLA) - thanks Elvis!

  1. Changing to ancestors' item identifies as treepath to fix potential performance issue during deleting/adding items
  2. Changing to baseless and module return value
  3. Code clean up

Refs #13542 regarding changing to baseless and module return value

comment:8 Changed 8 years ago by Evan

Resolution: fixed
Status: newclosed

In [26224]:

Fixes #13542 finished the last one file for baseless & module return value change

comment:9 Changed 8 years ago by Evan

In [26237]:

Refs #13542 !strict patch from Elvis(IBM, CCLA)

  1. adding missed changes of baseless & module return value(func sequence changed)
  2. improved keyboard focus & nls usages
  3. clean up

comment:10 Changed 8 years ago by Evan

In [26267]:

Refs #13542 !strict several missed fixes for module return value for Grid

comment:11 Changed 8 years ago by Evan

In [26404]:

Refs #13542, !strict adding the missed dependency on dojo/_base/event

comment:12 Changed 8 years ago by Evan

In [26650]:

Refs #13542 !strict, add comments, fix an page index calculation and test case fixes.

Note: See TracTickets for help on using tickets.