Opened 8 years ago

Closed 6 years ago

#13522 closed defect (wontfix)

Radio button created with dojo.create can't be selected in IE7

Reported by: Michael Schall Owned by: Eugene Lazutkin
Priority: high Milestone: tbd
Component: HTML Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

If you create a radio button using dojo.create in IE < 8, the value seems to be locked or unchangeable. You must use a non-standard document.createElement call to get the desired behavior.

View this link in IE7 to see the issue http://jsfiddle.net/RFNgt/1/

This code causes the problem in IE7:

dojo.create("input", {name: "clickable", type: "radio"}, dojo.byId("clickableContainer"));

This code works:

    dojo.place(document.createElement("<input type='radio' name='clickable' />"), dojo.byId("clickableContainer"));

Should/Could? dojo.create be handling this browser quirk?

Thanks

Mike

Change History (8)

comment:1 Changed 8 years ago by ben hockey

i'm trying with IE8 in IE7 mode. do you know if it should fail in that case? it seems to be working for me.

comment:2 Changed 8 years ago by bill

Component: CoreHTML
Owner: set to Eugene Lazutkin

comment:3 Changed 8 years ago by bill

In [27138]:

Fix regression from [26092] where StackContainer._selectedChildWidget doesn't get cleared on destroyDescendants(), leading to an exception if StackContainer.resize() is subsequently called. Possibly other problems too.

Exception originally showed up in TabContainer.html test on IE9 when the document mode (in IE developer console) was set to IE7 standards, since the window was getting on onresize event (even though the window size hasn't changed).

Refs #13522, fixes regression on trunk/, !strict.

comment:4 Changed 8 years ago by bill

In [27139]:

Fix regression from [26092] where StackContainer._selectedChildWidget doesn't get cleared on destroyDescendants(), leading to an exception if StackContainer.resize() is subsequently called. Possibly other problems too.

Exception originally showed up in TabContainer.html test on IE9 when the document mode (in IE developer console) was set to IE7 standards, since the window was getting on onresize event (even though the window size hasn't changed).

Refs #13522, fixes regression on 1.7/ branch, !strict.

comment:5 Changed 7 years ago by Eugene Lazutkin

I assume that two comments right above this comment got there accidentally.

comment:6 Changed 7 years ago by bill

Oops, sorry, you are right, those comments were for #13552 not this ticket.

comment:7 Changed 7 years ago by millennium

I can confirm this bug only happens in real IE7

It doesn't happen IE8 or IE9 in in IE7 Mode

comment:8 Changed 6 years ago by bill

Resolution: wontfix
Status: newclosed

Given the decline of IE7, probably this won't be fixed.

Note: See TracTickets for help on using tickets.