Opened 8 years ago

Closed 8 years ago

#13512 closed defect (fixed)

Some dojo.xxx methods are NOT available after building

Reported by: Ming Zhe Huang Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

OS: Win7 X64 Java: JDK 6 Engine: Rhino Optimizer: Shrinksafe Profile: demos-all

Some dojo.xxx methods are not available after building, for example, "dojo.require", "dojo.getObject", "dojo.isString".

This can be reproduced, by comparing the pre-build and post-build versions of the following cases. Try the attached test HTML. dojo.require is missing. Try mobileGagues demo. Try mobileCharting demo.

If you try the post-build version, you'll meet some NPE errors telling you certain methods are missing. But all work fine in pre-build version.

Attachments (2)

test.html (208 bytes) - added by Ming Zhe Huang 8 years ago.
build-report.txt (129.8 KB) - added by Ming Zhe Huang 8 years ago.
build report

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by Ming Zhe Huang

Attachment: test.html added

comment:1 Changed 8 years ago by dante

Milestone: tbd1.7

archerzz beat me to this ticket filing. A test can be seen in the nightly, any test in

http://archive.dojotoolkit.org/nightly/dojotoolkit/ is broken whereas the counterpart in the pre-built http://archive.dojotoolkit.org/nightly/checkout/ is fine.

I get "dojo.extend is not a function" loading themeTester, or DOH.

comment:2 Changed 8 years ago by bill

Looks like this is fixed now on the latest checkout (although nightly hasn't been refreshed yet).

comment:3 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: newclosed

appears to be OK on all fronts.

comment:4 Changed 8 years ago by Ming Zhe Huang

Resolution: fixed
Status: closedreopened

Some demos still fail to load after build. Please try to use demos-all profile and visit demos/mobileGauges/demo.html. The prebuild version is fine.

Console command: E:\src\dojo\trunk\util\buildscripts>build.bat profile=demos-all optimize=Shrinks afe layerOptimze=Shrinksafe cssOptimze=comments.keepLine

Changed 8 years ago by Ming Zhe Huang

Attachment: build-report.txt added

build report

comment:5 Changed 8 years ago by Rawld Gill

Resolution: worksforme
Status: reopenedclosed

Just attempted build as specified and it worked for me, including demos/mobileGauges/demo.html

I noticed the attached build-report is reporting a missing demos/package.json (look for warn 209). I doubt this is the issue, but it may indicate you have a stale checkout of one or more of the trees.

comment:6 Changed 8 years ago by Rawld Gill

Resolution: worksforme
Status: closedreopened

Looks like I spoke too soon. Noticing the problem again. Reopened.

comment:7 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: reopenedclosed

fixed in [25987]

Note: See TracTickets for help on using tickets.