Opened 8 years ago

Closed 6 years ago

#13479 closed defect (wontfix)

Dijit layout needs page refresh in Opera 11.50

Reported by: feklee Owned by:
Priority: low Milestone: future
Component: Dijit Version: 1.6.0
Keywords: opera, dijit, layout, rendering, bug Cc:
Blocked By: Blocking:

Description

How I experience the bug:

  1. Start Opera 11.50 on WinXP/32.
  1. Open in a new private tab (to keep the cache empty):

http://dojotoolkit.org/documentation/tutorials/1.6/dijit_layout/

  1. Click on "View Complete Demo":

http://dojotoolkit.org/documentation/tutorials/1.6/dijit_layout/demo/appLayout.html

  1. The layout is broken - see attachment.
  1. Click on another tab.
  1. Return to the demo page.
  1. Now the layout is OK. Seems like the page needs a refresh.

If you cannot reproduce the problem, try it on a slow machine.

Attachments (2)

broken-layout.png (14.6 KB) - added by feklee 8 years ago.
broken layout, as displayed in Opera 11.50/WinXP/32
demo.html (2.6 KB) - added by feklee 8 years ago.

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by feklee

Attachment: broken-layout.png added

broken layout, as displayed in Opera 11.50/WinXP/32

comment:1 Changed 8 years ago by Kenneth G. Franqueiro

Version: 1.7.0b11.6.0

I'm unable to reproduce this issue on Opera 11.50 on Windows 7 or Windows XP.

Also, just to clarify, switching tabs away and back isn't so much a refresh as a re-layout, it may be causing the browser to trigger resize events on the widgets.

The thought that a slow machine (or perhaps connection?) would cause the issue to happen suggests that maybe the external CSS is failing to load fast enough in your case? (Maybe Google CDN is slow to respond from your location?) I'd expect that kind of problem to potentially be reproducible regardless of browser, but haven't seen it happen on that page in any browser myself.

comment:2 Changed 8 years ago by feklee

I just made a local copy of the HTML file and the CSS. Result:

  • The problem is reproducible (always open in a *new* private tab).
  • The problem goes away when I set "isDebug: false", or when I include "dojo.xd.js" locally.

comment:3 Changed 8 years ago by feklee

See the attached file "demo.html". Here "claro.css" is loaded with a delay of two seconds. After loading in Opera 11.50 or Chrome 12, the layout is broken. Resizing the window will fix it.

However, the problem may be different than the one reported originally:

  • In Opera, just switching to another tab and back, does not fix the layout this time.
  • The broken layout looks different than in the provided screen shot.

By the way, first I tried loading "dojo.xd.js" with a delay. Unexpectedly, this did not have an effect.

Changed 8 years ago by feklee

Attachment: demo.html added

comment:4 Changed 8 years ago by bill

Milestone: tbdfuture

Opera isn't support by dijit, so marking this for future.

comment:5 in reply to:  4 Changed 8 years ago by feklee

Bill, as you can see in one of my comments, the problem also applies to Chrome 12. Could you rename the issue and change the milestone?

comment:6 Changed 8 years ago by bill

Milestone: futuretbd
Summary: Dijit layout needs page refresh in Opera 11.50Dijit layout needs page refresh in Chrome / Opera 11.50

I took a look on chrome. It's working for me. Not sure how to debug it.

comment:7 Changed 8 years ago by feklee

Bill, did you use the "demo.html" file that I provided when you tested in Chrome? Because, that's what shows the error. I have the "claro.css" be loaded delayed by two seconds.

comment:8 Changed 8 years ago by bill

Naturally there will be an error if you delay loading claro.css until after the page renders. That's expected.

comment:9 Changed 8 years ago by bill

Milestone: tbdfuture
Summary: Dijit layout needs page refresh in Chrome / Opera 11.50Dijit layout needs page refresh in Opera 11.50

OK, so other than that expected behavior, apparently the problem is only Opera. (At least I got no response to my comment above.) Opera isn't supported by dijit, so marking this for future.

comment:10 Changed 7 years ago by bill

Priority: highlow

comment:11 Changed 6 years ago by bill

Resolution: wontfix
Status: newclosed

Given that Opera is switching to the webkit engine, it doesn't make sense to look at these tickets. We can re-evaluate behavior of dijit on opera after the switch.

Note: See TracTickets for help on using tickets.