Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13472 closed defect (fixed)

incorrect slot value on dojox.mobile.SpinWheel after onFlickAnimationEnd event on Android

Reported by: Erwan Aullas Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.7.0b1
Keywords: spinwheel slot onFlickAnimationEnd Cc:
Blocked By: Blocking:

Description

I installed a callback function on onFlickAnimationEnd event on the slot I am interested into, to fetch the slot value when flicking is over. The code in the attached sample works well on desktop browsers, as well as iOs devices, but returns always the same value on android, no matter what value is displayed by the slot.

Android version : 2.2 froyo

Attachments (1)

SpinWheel-bug.html (1.8 KB) - added by Erwan Aullas 8 years ago.
incorrect slot value after spinning

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Erwan Aullas

Attachment: SpinWheel-bug.html added

incorrect slot value after spinning

comment:1 Changed 8 years ago by ykami

Resolution: fixed
Status: newclosed

In [26431]:

Fixes #13472 !strict. The cause of the problem was the android workaround code in scrollable.js. Disabled this workaround code since SpinWheel? does not need it.

comment:2 Changed 8 years ago by ykami

Milestone: tbd1.7
Note: See TracTickets for help on using tickets.