Opened 8 years ago

Closed 6 years ago

#13457 closed defect (fixed)

dojo tests fail in node

Reported by: liucougar Owned by: Rawld Gill
Priority: high Milestone: 1.8
Component: IO Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

37 test failures in node 0.4.7 with the following command:

node /absolute/path/to/dojo.js load=doh test=dojo/tests/module

most (if not all) test failures are due to undefined method connect or xhrGet

Attachments (1)

13457.patch (1.1 KB) - added by liucougar 8 years ago.
proposed patch to fix xhrGet undefined

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by liucougar

Attachment: 13457.patch added

proposed patch to fix xhrGet undefined

comment:1 Changed 8 years ago by liucougar

the attached patch fixes xhrGet undefined error in node.

with this patch, 20 test failures remain in node, caused by connect is undefined

comment:2 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:3 Changed 8 years ago by Adam Peller

Milestone: 1.71.7.1

comment:4 Changed 7 years ago by Rawld Gill

Milestone: 1.7.11.8

comment:5 Changed 7 years ago by Rawld Gill

Milestone: 1.82.0

comment:6 Changed 6 years ago by dylan

Component: GeneralIO
Milestone: 2.01.8
Resolution: fixed
Status: assignedclosed

I don't believe this is an issue any more. dojo/request works fine in Node in 1.8+

Note: See TracTickets for help on using tickets.