Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1344 closed defect (wontfix)

Get "Access is denied" in IE when call dojo.event.connect from inside IFrame in a different domain

Reported by: jonathan.aquino@… Owned by: alex
Priority: high Milestone:
Component: Events Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

When I call dojo.event.connect from inside an IFrame in a different domain in IE, I get an "Access is denied" error.

Test page: http://jonathanaquino.com/junk/dojo_tests/frameElement_id_error.html

This is happening when nameAnonFunc() accesses windowframeElement?. Perhaps a try/catch block could be used inside the loop to ignore exceptions? More info on this IE problem: http://w3schools.invisionzone.com/index.php?showtopic=5782

Change History (2)

comment:1 Changed 13 years ago by dylan

Resolution: wontfix
Status: newclosed

This is a cross-domain permissions issue, not a bug with Dojo. If I'm missing something here, please re-open.

comment:2 Changed 13 years ago by robert.coup@…

For future reference, this is the same issue as #998 and is fixed in [4820].

Note: See TracTickets for help on using tickets.