Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13414 closed defect (fixed)

Class names are removed on dojox.mobile.View

Reported by: nkzawa Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.7.0b1
Keywords: mobile View Cc:
Blocked By: Blocking:

Description

After onAnimationEnd, View's className is overwritten with "mblView". So classes that user add will be removed.

line 319: this.domNode && (this.domNode.className = "mblView");

This should be like: this.domNode && (this.domNode.className = "mblView " + thisclass?);

Change History (6)

comment:1 Changed 8 years ago by ykami

Milestone: tbd1.8

I was aware of that. Various classes are added internally before transition. It was simply hard to track what classes are internally added and thus have to be removed. It is a bit risky to fix this at this final stage. I will revisit this in the next release. You can write your styles for the mblView class in the meantime.

comment:2 Changed 8 years ago by ykami

Milestone: 1.81.7.1
Status: newassigned

The same problem was reported: #14225

comment:3 Changed 8 years ago by Kenneth G. Franqueiro

Milestone: 1.7.11.8

Not sure why this was moved up to 1.7.1; is it only reproducible in 1.7?

If it was "risky" to fix 3 months before 1.7's release, that sounds too risky for a patch release to me, but I'm willing to hear the other side of the story.

comment:4 Changed 8 years ago by ykami

That was because the reporter of #14225 raised this problem as priority:high, severity:critical, and we found a solution that does not require tracking of all the internal classes. But I'm fine to defer this to 1.8.

comment:5 Changed 8 years ago by ykami

Resolution: fixed
Status: assignedclosed

In [27161]:

Fixes #13414 !strict. Added _clearClasses() to remove only the internally added classes.

comment:6 Changed 8 years ago by Kenneth G. Franqueiro

I know I kinda barged in and punted this earlier, but I'd like to amend that if appropriate: if this is an issue specifically with 1.7.0, I could totally understand its applicability for 1.7.1 and would be ok with applying it to the 1.7 branch as long as we have a test case to confirm it and are confident it doesn't cause regressions.

I initially punted it mainly because I saw it bumped forwards from 1.8 to 1.7.1, and was initially trying to narrow down what was most applicable (as we are gearing towards a 1.7.1 sooner rather than later).

Last edited 8 years ago by Kenneth G. Franqueiro (previous) (diff)
Note: See TracTickets for help on using tickets.