Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1338 closed defect (worksforme)

Combobox - Dropdown displays under buttons (IE 6.0.2800.1106)

Reported by: jpowers@… Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

In the following code page on IE 6.0; the dropdown on the Combobox(Employer) is displayed under the buttons on the "Profile" tab. It works correctly on FireFox? 1.5.06. I'm using the release version of 0.3.1.

<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN" "http://www.w3.org/TR/1999/REC-html401-19991224/loose.dtd"> <HTML> <HEAD> <TITLE>iSeries Self Help</TITLE> <script type="text/javascript" src="dojo-0.3.1-ajax/dojo.js"></script> <script language="JavaScript?" type="text/javascript">

dojo.require("dojo.widget.LayoutContainer?"); dojo.require("dojo.widget.ContentPane?"); dojo.require("dojo.widget.TabContainer?"); dojo.require("dojo.widget.validate"); dojo.require("dojo.widget.ComboBox?"); dojo.require("dojo.widget.Button"); dojo.widget.validate.ValidationTextbox?.prototype.validColor="white"; dojo.hostenv.writeIncludes();

</script> <script type="text/javascript">

function InputOk?() {

var Profile = dojo.widget.byId('Profile'); var Employer = dojo.widget.byId('Employer'); var Employee = dojo.widget.byId('Employee'); var SSN = dojo.widget.byId('SSN'); var Birthday = dojo.widget.byId('Birthday'); var result = true;

if( Profile.isEmpty() ) result = false; if( Employer.isEmpty() ) result = false; if( Employee.isEmpty() ) result = false; return result;

}

function ChangeProfile?(type) {

if( InputOk?()) {

alert(type);

} else {

alert('Bad data');

}

}

</script> <style type="text/css">

html, body{

width: 100%; /* make the body expand to fill the visible window */ height: 100%; overflow: hidden; /* erase window level scrollbars */ padding: 0 0 0 0; margin: 0 0 0 0;

} .formQuestion {

padding:0.3em; font-weight:900; font-family:Verdana, Arial, sans-serif; font-size:0.8em; color:#5a5a5a;

} .formAnswer {

padding:0.3em; margin-bottom:1em; width: 100%;

} .pageSubContentTitle {

color:#8e8e8e; font-size:1em; font-family:Verdana, Arial, sans-serif; margin-bottom:0.75em;

} .small {

width: 2.5em;

} .medium {

width: 10em;

} .long {

width: 20em;

}

span.invalid, span.missing {

display: inline; margin-left: 1em; font-weight: bold; font-style: italic; font-family: Arial, Verdana, sans-serif; color: #f66; font-size: 0.9em;

}

.noticeMessage {

display: block; float: right; font-weight: normal; font-family:Arial, Verdana, sans-serif; color:#663; font-size:0.9em;

} /* group multiple buttons in a row */ .box {

display: block; text-align: center;

} .box .dojoButton {

float: left; margin-right: 10px;

} .dojoButton .dojoButtonContents {

font-size: medium;

}

</style> </HEAD> <body> <div dojoType="LayoutContainer?"

layoutChildPriority='top-bottom' style="width: 100%; height: 100%; background-color: #FFFE68"

<div dojoType="ContentPane?" layoutAlign="top" style="background-color: #274383; color: white;">

iSeries Self Help

</div> <div dojoType="ContentPane?" layoutAlign="bottom" style="background-color: #274383; color: white;">

Copyright (c) 2006 MGM MIRAGE. All rights reserved.

</div> <div id="mainTabContainer" dojoType="TabContainer?" sizeMin="20" sizeShare="70" layoutAlign="client">

<div id="Welcome" dojoType="ContentPane?" Label="Welcome" Style="background-color: #e3f3f6">

<BR /> <div align="center"><img src="Images/corp40.gif" /></div> <h1 align="center">Welcome to iSeries Self Help</h1> <BR /> <p>This system is designed to help you fix some issue your self without having to call

the help desk. If you can't find a solution to your problem on this page, please feel free to call the Help Desk at (702) 650-6999. They will be more then happy to help you with your issue.

</p> <p>Currently this site is limited to enabling/resetting your user profile and reactivating

a disabled terminal.

</p>

</div> <div id="ProfileTab?" dojoType="ContentPane?" Label="Profile" Style="background-color: #e3f3f6">

<form method="get" id="form1">

<div class="formQuestion">

<span class="noticeMessage">You can only reset the profile assigned to you...</span> <span class="emphasise">Profile and Your Information</span>

</div> <table class="formAnswer" style="width: 100%;">

<tr>

<td class="emphasise">Profile</td> <td width="100%">

<input type="text" name="Profile" class="medium" id="Profile"

dojoType="ValidationTextBox?" maxlength="10" required="true" trim="true" missingMessage="Enter your iSeries user name; this may be

different then your Windows sign-on."

/>

</td>

</tr> <tr>

<td class="emphasise">Employer</td> <td>

<select name="Employer" dojotype="combobox" id="Employer"

dataurl="secbin/CUGER.PGM" style="width: 350px;" autocomplete="true" maxListLength="10"

/>

</td>

</tr> <tr>

<td class="emphasise">Employee#</td> <td>

<input type="text" name="Employee" class="medium"

dojoType="ValidationTextBox?" required="true" trim="true" missingMessage="Enter your employee #; this should be on your

Employee ID card."

/>

</td>

</tr> <tr>

<td class="emphasise">Pin#</td> <td>

<input type="text" name="SSN" class="medium"

dojoType="IntegerTextBox?" trim="true" required="true" min="0" max="9999" missingMessage="Enter the last 4 digits of your SSN."

/>

</td>

</tr> <tr>

<td class="emphasise">Birthday</td> <td>

<input type="text" name="Birthday" class="medium"

dojoType="DateTextBox?" trim="true" required="true" invalidMessage="Invalid date. Use MM/DD/YYYY format." missingMessage="Please enter your birthday. Use MM/DD/YYYY format."

/>

</td>

</tr>

</table> <br /> <br /> <table align="center">

<tr>

<td>

<button dojoType="Button" onclick="ChangeProfile?('Enable')">Enable and Keep Password</button>

</td> <td>

<button dojoType="Button" onclick="ChangeProfile?('Reset')">Enable and Reset Password</button>

</td>

</tr>

</table>

</form>

</div>

</div>

</div> </body> </HTML>

Change History (4)

comment:1 Changed 13 years ago by dylan

Milestone: 0.4

sounds like this widget needs the background iframe hack.

comment:2 Changed 13 years ago by doughays@…

Using the latest nightly, everything seems to work OK for me. I'm using IE 6.0.2900.2180.xpsp.051011-1528 (XP SP2). Since I didn't have access to dataurl="secbin/CUGER.PGM" referenced in the testcase, I manually added several <option> tags. If it's still a problem, please include a self-contained testcase.

comment:3 Changed 13 years ago by bill

Resolution: worksforme
Status: newclosed

Closing this bug for now, unless/until it can be reproduced against the latest code.

comment:4 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.