Opened 8 years ago

Closed 8 years ago

#13311 closed defect (worksforme)

editor demo broken

Reported by: bill Owned by:
Priority: high Milestone: tbd
Component: General Version: 1.7.0b1
Keywords: Cc: Rawld Gill
Blocked By: Blocking:

Description

It tries to load layer.js via a <script> tag, which is illegal with the new AMD loader (you need to use dojo.require(). But also, layer.js doesn't exist in the non-built version of the demo, so even a dojo.require() will give an error.

I'm not sure how this is supposed to be handled, Rawld can you comment?

Working in 1.6 but broken in 1.7.

Change History (2)

comment:1 Changed 8 years ago by Rawld Gill

I just tried both demo.html an demoFast.html, both built and unbuilt on FF, Chrome, Safari, IE8 and all four worked for me.

The new loader will consume a resource loaded by a <script> tag. Problems tend to happen when code both (1) loads with a <script> tag, and (2) loads the same resource consequent to a require/define. Since this doesn't happen in this app the way it's coded, it's not a problem. The non-built versions will try to load the non-existing layer.js, but that doesn't seem to cause a problem.

If the <script> load is changed to a require application, then a layer module will have to be added; otherwise the loader will fail to load the app...at least in sync mode.

comment:2 Changed 8 years ago by bill

Resolution: worksforme
Status: newclosed

Ah OK, it's working for me now too, nevermind.

Note: See TracTickets for help on using tickets.