Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13307 closed defect (fixed)

url.js causes script error if compiled with closure

Reported by: ykami Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

dojo/_base/url.js causes a script error (unterminated string literal) if it is built with the closure compiler.

Steps to reproduce:

  1. Do custom base build as follows:
build action=release profile=standardCustomBase optimize=closure
  1. Open this html.
<html>
<head>
<script src="dojo/dojo.js"></script>
<script>
	dojo.require("dojo._base.url");
</script>
</head>
<body>
</body>
</html>

(The above is to present a minimal code to reproduce the problem. In real scenarios, just requiring dojo.parser causes this error, because dojo.parser has dependency on dojo._base.url.)

This error occurs on any browsers. (tested with IE, Firefox, and Chrome)

Shrinksafe does not have this problem.

Change History (4)

comment:1 Changed 8 years ago by Douglas Hays

Component: GeneralBuildSystem
Owner: set to Rawld Gill

Could this be a closure compiler bug? I pasted the code into http://closure-compiler.appspot.com/home and selected "Advanced". dojo._Url = _Url turned into h.d = f; but "d" was never defined. There were 2 warnings about not being allowed to do "new _Url".

comment:2 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: newclosed

Could not duplicate the closure compiler parsing error; this was likely resolved in [25678].

standardCustomBase references non-existing dojo/_base.js. This was fixed in [25932], which fixes this ticket.

comment:3 Changed 8 years ago by bill

Milestone: tbd1.7

comment:4 Changed 8 years ago by ykami

Verified. Thank you!

Note: See TracTickets for help on using tickets.