Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13289 closed defect (fixed)

dojo.gesture - muti-touch gestures are not fired appropriately when registered on different targets simultaneously

Reported by: evan Owned by: evan
Priority: high Milestone: 1.7
Component: Core Version: 1.7.0b1
Keywords: Cc: Evan
Blocked By: Blocking:

Description

This will happen if user want to write a 3rd gesture that supports multiple touches - e.g. a multi-touch swipe to get a similar behavior in the game of 'Fruit Ninjia'

The cause is gesture data need to be kept isolated and clean for different gesture targets.

Change History (6)

comment:1 Changed 8 years ago by evan

Resolution: fixed
Status: newclosed

(In [25700]) Fixes #13289 isolating gesture data for separate elements so that we can support more advanced multi-touch gestures e.g. an advanced swiping similarly used in the 'Fruit Ninjia' game.

comment:2 Changed 8 years ago by evan

(In [25702]) Refs #13289 and full DoH test cases in AMD manner

comment:3 Changed 8 years ago by evan

Milestone: tbd1.7

comment:4 Changed 8 years ago by evan

(In [25707]) Refs #12591 changed to use isolated gesture data rather then gestureElement, based on fix - refs #13289

comment:5 Changed 8 years ago by evan

(In [25765]) Refs #13289 !strict comments updates; tap/swipe currently only support single touch so add corresponding sane check

comment:6 Changed 8 years ago by Evan

Cc: Evan added
Note: See TracTickets for help on using tickets.