Opened 8 years ago

Closed 7 years ago

#13280 closed defect (duplicate)

dojox.form.BusyButton onClick is broken

Reported by: jekser Owned by: dante
Priority: high Milestone: tbd
Component: DojoX Form Version: 1.7.0b1
Keywords: dojox.form.BusyButton, onClick Cc:
Blocked By: Blocking:

Description

dojox.form.BusyButton? onClick is broken:

<button type="button" data-dojo-type="dojox.form.BusyButton">Click
  <script type="dojo/connect" data-dojo-event="onClick">
    alert("Click");
    this.cancel();
  </script>
</button>

I can only connect to private _onClick event. Following code works

<button type="button" data-dojo-type="dojox.form.BusyButton">Click
  <script type="dojo/connect" data-dojo-event="_onClick">
    alert("Click");
    this.cancel();
  </script>
</button>

Change History (1)

comment:1 Changed 7 years ago by mikeb

Resolution: duplicate
Status: newclosed

This looks like a dupe of #13364 which was fixed in http://bugs.dojotoolkit.org/changeset/25749/dojo

Note: See TracTickets for help on using tickets.