Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13262 closed defect (worksforme)

Dialog: double delete in show() and hide() methods

Reported by: waynevicknair Owned by: bill
Priority: high Milestone: 1.7
Component: Dijit Version: 1.7.0b1
Keywords: Cc: Adam Peller
Blocked By: Blocking:

Description (last modified by bill)

both the anonymous function in the dojo.Deferred constructor and the onEnd method of fadeIn/fadeOut delete 'this._fade(In|Out)Deferred'. first one works; second one throws Error.

Change History (4)

comment:1 Changed 8 years ago by bill

Description: modified (diff)
Milestone: tbd1.7
Owner: set to bill
Status: newassigned
Summary: double delete in Dialog show() and hide() methodsDialog: double delete in show() and hide() methods

Makes sense, I'll remove one, thanks.

comment:2 Changed 8 years ago by bill

Hmm, actually, I don't understand, the "anonymous function" that you are referring to is the canceller, for when you cancel the animation mid-stream, but the onEnd() function is for when the animation continues to the end without being canceled.

What situation are you seeing the double remove on? It's not reproducing for me, using test_Dialog.html.

comment:3 Changed 8 years ago by bill

Resolution: worksforme
Status: assignedclosed

I'm going to mark this as worksforme, but will reopen if/when you supply a test case and instructions for reproducing the bug (or instructions about how to reproduce on existing test case).

comment:4 Changed 8 years ago by waynevicknair

duplicate of ticket #12436 which is fixed in dojo1.7.

Note: See TracTickets for help on using tickets.