Opened 8 years ago

Closed 8 years ago

#13260 closed defect (fixed)

CheckedMenuItem doesn't have checkbox icon

Reported by: siqi Owned by: bill
Priority: blocker Milestone: 1.7
Component: Dijit Version: 1.7.0b1
Keywords: CheckedMenuItem, icon Cc: zhongsq@…
Blocked By: Blocking:

Description (last modified by bill)

Open dijit/tests/test_Menu.html, you can find these CheckedMenuItems('checked', 'not checked', 'checked disabled') which are on the left side don't have checkbox icon.

This issue is caused by the fix for #12857 !strict. The fix makes "dijitNoIcon" the default value of iconClass for dijit.MenuItem.

dijit.CheckedMenuItem should overwrite iconClass with an empty string "" to fix the issue.

Change History (2)

comment:1 Changed 8 years ago by bill

Component: Dijit - FormDijit
Description: modified (diff)
Milestone: tbd1.7
Owner: changed from Douglas Hays to bill
Status: newassigned

Ah, that's my fault, I'll fix, thanks for catching it.

comment:2 Changed 8 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [25556]) Fix display of checkmark icon for CheckedMenuItem, refs #12857, fixes #13260 !strict.

Note: See TracTickets for help on using tickets.