Opened 8 years ago

Closed 7 years ago

#13253 closed defect (duplicate)

Tree: row becomes detached from the tree using Drag and Drop quickly

Reported by: matt.asbury Owned by: bill
Priority: high Milestone: tbd
Component: Dijit Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Eugene Lazutkin)

When using the dijit.Tree and Drag and Drop functionality, trying to move items around quickly causes them to be permanently detached from the tree. Although discovered in a web app I am working on, I am able to replicate the bug in the dojo example page http://dojotoolkit.org/reference-guide/dijit/Tree.html under the Drag and Drop example shown in http://yfrog.com/h3rtq6wj and here:

http://a.yfrog.com/img615/5483/rtq6w.jpg

To replicate, drag items from the top of the tree lower down as fast as you can. In Firebug the following error messages are displayed for each detached item:

_6c is null [dojo.js line 552]
_26.getParent() is null [dojo.js line 187]

I can replicate this in all browsers I have tested (IE7, IE8, FF4, Chrome 13).

Change History (4)

comment:1 Changed 8 years ago by matt.asbury

This seems to be related to this ticket - http://bugs.dojotoolkit.org/ticket/7971

comment:2 Changed 8 years ago by bill

Milestone: tbd

comment:3 Changed 7 years ago by Eugene Lazutkin

Component: DnDDijit
Description: modified (diff)
Owner: changed from Eugene Lazutkin to bill
Status: newassigned

Am I correct assuming that this is purely Dijit ticket? Let me know, if I can help from the DnD side.

comment:4 Changed 7 years ago by bill

Resolution: duplicate
Status: assignedclosed
Summary: DijitTreeRow becoming detached from the tree using Drag and DropTree: row becomes detached from the tree using Drag and Drop quickly

Duplicate of #7971.
Probably this was fixed by #7971.

Note: See TracTickets for help on using tickets.