Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1325 closed defect (fixed)

[regression] Problems in dojo.string.Builder since rev 4811

Reported by: guest Owned by: Tom Trenka
Priority: high Milestone:
Component: String Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

Since rev 4811 dojo.string.Builder has a major problem when appending a number.

The following code will fail (sb is a StringBuilder?):

sb.append(1);

This code will work:

sb.append("1");

It used to work earlier and IMHO, this is a bug.

For more info you can contact me at "stefan at wingio.de".

Stefan

Change History (5)

comment:1 Changed 13 years ago by dylan

Milestone: 0.4
Summary: Problems in dojo.string.Builder since rev 4811[regression] Problems in dojo.string.Builder since rev 4811
Version: 0.20.3

The patch in #4811 definitely removed this capability. Alex, was this intentional?

comment:2 Changed 13 years ago by Tom Trenka

Owner: changed from alex to Tom Trenka

Reassigning to me.

comment:3 Changed 13 years ago by Tom Trenka

Resolution: fixed
Status: newclosed

(In [5811]) Fixes #1437.

comment:4 Changed 13 years ago by Tom Trenka

Dammit. Fixed (In [5811]).

comment:5 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.