Opened 9 years ago

Closed 9 years ago

#13239 closed defect (fixed)

Menu: loses focus when clicking nested submenu

Reported by: bill Owned by: bill
Priority: high Milestone: 1.7
Component: Dijit Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

To reproduce, see test_Menu.html:

  1. Open View menu
  2. Open Zoom submenu
  3. Click anything

Since the Zoom menuitems (ex: 100%) don't set focus anywhere, focus should revert to the "View" MenuBarItem. But it doesn't.

Change History (1)

comment:1 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [25519]) When closing tree of submenus, and checking if focus should be restored to root menu, check if focus was on a descendant menu rather than checking if it's on a direct child. Fixes #13239 !strict.

Note: See TracTickets for help on using tickets.