Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13232 closed defect (fixed)

runner.html does not add parsed paths to require config object

Reported by: tommahieu Owned by: haysmark
Priority: high Milestone: 1.7
Component: TestFramework Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

The URL paths (and registerModulePath) parameter passed to runner.html is parsed, but not passed to the require config object.

Consequently, test modules in directories that are not siblings to the dojo directory can never be loaded.

Attachments (2)

runner.html.diff (672 bytes) - added by tommahieu 8 years ago.
patch adding paths property to require config object
mytests.zip (1.2 KB) - added by tommahieu 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by tommahieu

Attachment: runner.html.diff added

patch adding paths property to require config object

comment:1 Changed 8 years ago by Douglas Hays

Owner: alex deleted

comment:2 Changed 8 years ago by Douglas Hays

Owner: set to haysmark

Mark, there's no testcase provided. Can you try to recreate this and commit the patch if appropriate?

Changed 8 years ago by tommahieu

Attachment: mytests.zip added

comment:3 Changed 8 years ago by tommahieu

I attached the testcase that I've used (sorry for the inconvenience, I should have done that immediately). File structure on the server is as follows

Server root
|-- mytests
|   |-- coretest.html
|   |-- module.js
|   +-- runTests.html
+-- src
    |-- dijit
    |-- dojo
    |-- dojox
    |-- util

Note that I also had to apply #13234 on 1.7.0b1 before I could get the tests running

comment:5 Changed 8 years ago by haysmark

Resolution: fixed
Status: newclosed

(In [25651]) Add back "paths" variable, aka registerModulePath, lost in AMD refactor. Fixes #13232.

comment:6 Changed 8 years ago by haysmark

Milestone: tbd1.7

comment:7 Changed 8 years ago by tissandier

Hello,

It seems the problem is only half fixed. The solution seems to work for a simple module name 'myModule', but not for a composed path : 'my.module'

Note: See TracTickets for help on using tickets.