Opened 8 years ago

Closed 8 years ago

#13216 closed defect (fixed)

Build Tool Pulls in Excessive Dependencies into Layer Files of Demos

Reported by: Ming Zhe Huang Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

OS: Win7 X64 Optimizer: Shrinksafe/Closure? JS Engine: Rhino Profile: Any profile containing layer definition for demo app

Today I use my own build profile(please see the attached mobileGallery.profile.js) to build mobile gallery. I found the size of the demos/mobileGallery/src.js is very large. It pulls in excessive dependencies. For example, dojo/window is pulled in. However, according to the profile definition, "dojo.window" should be pulled into dojo.js.

After some investigation, the synopsis is that if you define an independent layer for a demo app, then the target layer file will pull in excessive dependencies. You can check the built src.js files of other demo app, using the attached profile. You'll find that they do NOT pull in excessive dependencies.

If you try demos-all.profile.js, you'll find that all src.js files of demo apps will pull in excessive dependencies.

Attachments (1)

mobileGallery.profile.js (1.8 KB) - added by Ming Zhe Huang 8 years ago.
Build profile of mobileGallery

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by Ming Zhe Huang

Attachment: mobileGallery.profile.js added

Build profile of mobileGallery

comment:1 Changed 8 years ago by Ming Zhe Huang

demos-all.profile.js defines layer files for each demo app, that's why all src.js files of demo apps pull in excessive dependencies.

comment:2 Changed 8 years ago by Chris Mitchell

Milestone: tbd1.7
Priority: normalhigh

comment:3 Changed 8 years ago by zhangyp

The problem is that the independent layer will pull in duplicate javascript modules which has already been pulled in dojo layer. And this problem severely affect all dojo demos with independent layers in build file.

comment:4 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: newclosed

(In [25571]) fixed typo in layer exclusion calculation; fixes #13216

Note: See TracTickets for help on using tickets.