Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13211 closed defect (fixed)

[ccla] GFX: Using the Canvas renderer on Chrome, white arabic characters are not visible

Reported by: Eric Durocher Owned by: Eugene Lazutkin
Priority: high Milestone: 1.8
Component: DojoX GFX Version: 1.7.0b1
Keywords: gfx canvas arabic white Cc: edurocher@…
Blocked By: Blocking:

Description

In a GFX surface, using the Canvas renderer, if a Text shape contains Arabic characters and has a white fill color, the Arabic characters are not visible. Black text works OK.

To reproduce, drop the attached sample to dojox/gfx/tests and launch it using Chrome. The Arabic part of the white text is not visible.

Attachments (1)

arabic.html (2.1 KB) - added by Eric Durocher 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by Eric Durocher

Attachment: arabic.html added

comment:1 Changed 8 years ago by Patrick Ruzand

This is a Chrome bug. Reproduced in pure html 5. see http://code.google.com/p/chromium/issues/detail?id=86165 (with the testcase).

comment:2 Changed 8 years ago by Chris Mitchell

Resolution: fixed
Status: newclosed

does #FFFFF work in place of "white" possible workaround to test for chrome version and arabic, then if "white" set FFFFFF or FFFFFE (something close to white)?

comment:3 Changed 8 years ago by Chris Mitchell

Resolution: fixed
Status: closedreopened

unintentionally closed

comment:4 Changed 8 years ago by Patrick Ruzand

comment:5 Changed 8 years ago by Patrick Ruzand

Resolution: fixed
Status: reopenedclosed

comment:6 Changed 8 years ago by Patrick Ruzand

Since it is fixed in chrome, I close it.

Note: See TracTickets for help on using tickets.