Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13210 closed defect (worksforme)

test_ScrollableMixin-custom crashes Android 2.2.1

Reported by: haysmark Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.7.0b1
Keywords: android Cc: Atsushi Ono
Blocked By: Blocking:

Description

See:

http://archive.dojotoolkit.org/nightly/checkout/dojox/mobile/tests/test_ScrollableMixin-custom.html

On Android 2.2.1, the list has a yellow background with a red border around page. You can scroll the list with just one finger touch, but when you let go, the browser crashes.

On Android 2.1, the list has a white background and is not scrollable, even with two fingers (perhaps there is a JavaScript? error?).

Change History (7)

comment:1 Changed 8 years ago by ykami

Cc: Atsushi Ono added
Keywords: android added

comment:2 Changed 8 years ago by ykami

Are you still able to reproduce this problem?
I tried it with galaxy tab and HTC Desire, but could not reproduce the problem.

comment:3 Changed 8 years ago by haysmark

Android 2.1: no more issues on Droid Eris and x86 build. Android 2.2: no issues in emulator, don't have any devices to test. Android 2.2.1: in the x86 build, the browser still crashes. don't have any devices to test.

comment:4 Changed 8 years ago by ykami

I tried it with Android emulator 2.1-update1 - API Level 7. If dojox.mobile is built, test_ScrollableMixin-custom worked fine. If dojox.mobile is not built, however, it didn't work and I saw "JavaScript execution exceeded timeout" error in the JavaScript console. In this case, the timeout error occurs even on other test cases, so probably this is not your problem. Any ideas on how I can reproduce the problem? Did you use built dojo, or non-built (source code) dojo?

comment:5 Changed 8 years ago by haysmark

Right the emulator is too slow, the x86 build is our only hope.

I flashed a Motorola Droid X to 2.2.1 and tried the test and it did not crash. I guess it is just a driver problem in the x86 build.

comment:6 Changed 8 years ago by ykami

Resolution: worksforme
Status: newclosed

comment:7 Changed 8 years ago by ykami

Milestone: tbd1.7
Note: See TracTickets for help on using tickets.