Opened 8 years ago

Closed 8 years ago

#13199 closed defect (duplicate)

In IE8/VML, Event handlers set on a Rect are lost after a setShape() call.

Reported by: Patrick Ruzand Owned by: Eugene Lazutkin
Priority: high Milestone: tbd
Component: DojoX GFX Version: 1.5
Keywords: Cc: pruzand@…
Blocked By: Blocking:

Description

Under IE8 with the VML renderer, event handlers connected to a Rect via rect.connect() are lost after the rect shape is updated via setShape(). The following sequence illustrates the problem:

var rect = surface.createRect();

rect.connect('onmousedown', function(){...});

and later:

rect.setShape(newShape)

The problem is that under IE8, Rect.setShape replaces the shape rawNode by a new one (seems to workaround a round corner vml bug). So all connections done on the previous rawNode are lost.

Attachments (1)

test_rectConnect.html (1.9 KB) - added by Patrick Ruzand 8 years ago.
testcase

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by Patrick Ruzand

Attachment: test_rectConnect.html added

testcase

comment:1 Changed 8 years ago by Patrick Ruzand

Resolution: duplicate
Status: newclosed

duplicate of #11552

Note: See TracTickets for help on using tickets.