Opened 9 years ago

Closed 8 years ago

#13174 closed defect (invalid)

Error Bundle not found: gregorian in dojo.cldr , locale=es-es with dojo 1.5 and firefox 4

Reported by: fdiazr Owned by: Adam Peller
Priority: high Milestone: tbd
Component: Internationalization Version: 1.5.0b1
Keywords: Bundle not found: gregorian in dojo.cldr, locale=es-es Cc:
Blocked By: Blocking:

Description

When i opened a new dialog who contain a DateTextBox?, i'm getting the following error:

Bundle not found: gregorian in dojo.cldr , locale=es-es

This is only in firefox 4.01 in Mac OSX

Attachments (3)

Captura de pantalla 2011-06-04 a las 6.30.07 p.m..png (155.5 KB) - added by fdiazr 9 years ago.
error screen
network tab firebug.zip (189.1 KB) - added by fdiazr 8 years ago.
network tab from firebug
instrucctions.txt (1.5 KB) - added by fdiazr 8 years ago.

Download all attachments as: .zip

Change History (20)

Changed 9 years ago by fdiazr

error screen

comment:1 Changed 9 years ago by Adam Peller

Component: GeneralInternationalization
Resolution: invalid
Status: newclosed

There is not enough information here to reproduce the bug. A short test case would be required. Are you specifying the locale on your page? What is the value of dojo.locale? Are all of the nls files deployed to your server?

comment:2 Changed 8 years ago by fdiazr

Resolution: invalid
Status: closedreopened

1- I tried without locale and harcoding the locale 'es-es' and 'es', but don't work.

  1. The dojo locale it's taking the browser default locale: 'es-es'
  2. i have downloaded the dojo version from the server. Looking my files deployed i found a directory in 'dojo\nls' on this directory appears many files directory. i see a 'es' directory, i don't know if 'es-es' directory it is necessary. All files are as i downloaded from dojo site.

I tried to use dojo 1.5.1 and 1.6 version, on both i get same error.

comment:3 Changed 8 years ago by fdiazr

This problem don't occurs in google chrome.

when i try to generate a new build it's still happen. tested in firefox 3.6 and 4.01 on windows and mac osx, don't work.

comment:4 Changed 8 years ago by Adam Peller

chances are, it's not that the bug is specific to a particular browser, but that the browsers are using different locales (es vs es-es) Check the values navigator.language and dojo.locale in the console.

You could try including 'es-es' in the localeList parameter for the build script, but I don't think that should be necessary.

comment:5 Changed 8 years ago by Adam Peller

If you hit this url, do you see the same problem? This is a standard Dojo build

http://download.dojotoolkit.org/release-1.6.1/dojo-release-1.6.1/dijit/tests/form/test_DateTextBox.html

comment:6 Changed 8 years ago by Adam Peller

you may also want to look in the network console and see if there are any 404s

comment:7 Changed 8 years ago by fdiazr

Thank you for your response.

looking for my console i dont have any 404 error. When i visit the page you refer i dont have any problem. but I encountered when i work with a source version 1.5 everythink its ok, but when i build a release the problem appear. I create the release from dojo source using the following command:

./build.sh action=release profile=standard

Then i copy the release directory to my dojo directory, give all permissions to the web server. Then te problem appear. The problem also occurs when i click or use a combobox.

What can i do? or what i doing bad?

comment:8 Changed 8 years ago by fdiazr

ok this is another try:

in the console the navigator.language is "es-ES". It's not must be 'es-es', in lower case?

The dojo.locale is 'es-es' not the same of navigator.language.

i build the version using 'es-es' in the localeList but still not working.

comment:9 in reply to:  4 Changed 8 years ago by fdiazr

Replying to peller:

chances are, it's not that the bug is specific to a particular browser, but that the browsers are using different locales (es vs es-es) Check the values navigator.language and dojo.locale in the console.

You could try including 'es-es' in the localeList parameter for the build script, but I don't think that should be necessary.

ok this is another try:

in the console the navigator.language is "es-ES". It's not must be 'es-es', in lower case?

The dojo.locale is 'es-es' not the same of navigator.language.

i build the version using 'es-es' in the localeList but still not working.

comment:10 Changed 8 years ago by fdiazr

When i check the firefox preferences the default language is 'es' the second one is 'es-es'

comment:11 in reply to:  8 Changed 8 years ago by Adam Peller

Replying to fdiazr:

in the console the navigator.language is "es-ES". It's not must be 'es-es', in lower case?

That's fine.

The dojo.locale is 'es-es' not the same of navigator.language.

That's correct. It converts to lowercase.

i build the version using 'es-es' in the localeList but still not working.

Can you create a simple page with this problem, or perhaps copy the test I mentioned with its dependencies to your build and see if you can reproduce the problem?

Could you try to capture the results from the 'network' panel of firebug and attach them here?

comment:12 in reply to:  10 Changed 8 years ago by Adam Peller

Replying to fdiazr:

When i check the firefox preferences the default language is 'es' the second one is 'es-es'

navigator.language has nothing to do with the preferences, unfortunately. the preferences only define what is sent with http request headers. navigator.language is fixed unless you find a plugin to change its value.

Changed 8 years ago by fdiazr

Attachment: network tab firebug.zip added

network tab from firebug

comment:13 Changed 8 years ago by fdiazr

This is the HTML code im trying to do. The error occurs in line if(dijit.byId('myForm3').validate())

If i use the dojo source its works, and if i use the dojo release (downloaded from web) its does not work. this code its embeded into dialog.

comment:14 Changed 8 years ago by fdiazr

For some reason i can't put the links to a example application who reproduce the error. I wrote the instruccions and details in instrucctions.txt attached file, please read.

I put two links examples of two pages, one using the dojo source version and the other using the release version, on work and the other no.

Changed 8 years ago by fdiazr

Attachment: instrucctions.txt added

comment:15 Changed 8 years ago by fdiazr

???

comment:16 Changed 8 years ago by Douglas Hays

Owner: set to Adam Peller
Status: reopenednew

comment:17 Changed 8 years ago by Adam Peller

Resolution: invalid
Status: newclosed

This type of error is usually caused by code references to i18n bundles prior to page load. Note also that there are references to dijit (e.g. dijit.Dialog) which must be wrapped in a dojo.ready() call.

Note: See TracTickets for help on using tickets.