Opened 8 years ago

Closed 8 years ago

#13167 closed defect (fixed)

error loading demos/skew/demo.html

Reported by: bill Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: Loader Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

This is from running demos/skew/demo.html on FF3.6, non-build.

The error that appears is

declare dojox.widget.DialogSimple: mixin #0 is not a callable constructor.

I traced it to:

  1. dojox/widget/DialogSimple.js's define() statement starts running, and loading dependencies
  2. dojox/layout/ContentPane.js (non-AMD format) starts executing
  3. dojox/layout/ContentPane.js calls dojo.require("dojox.html._base");
  4. then dojox.widget.DialogSimple's callback starts executing, even though ContentPane hasn't finished loading yet.

Change History (2)

comment:1 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:2 Changed 8 years ago by bill

Milestone: tbd1.7
Resolution: fixed
Status: assignedclosed

Trac missed Rawld's checkin: (In [25409]) improved dependency tracing to be more conservative in sync+/-xdomain modes with particular fixes to eliminating cycles caused by has plugin; fixes #13167; fixes #13088; !strict

Note: See TracTickets for help on using tickets.