Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13158 closed defect (worksforme)

dijit.form.ComboBox malfunction when in dojox.layout.FloatingPane

Reported by: Liubomir Armoutliev Owned by: Douglas Hays
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

When Combobox or FilteringSelect? are placed in a FloatingPane? you can open the dropdown only when you click on the arrow. Normally it opens when you click anywhere on the button node.

Change History (9)

comment:1 Changed 8 years ago by Liubomir Armoutliev

Can be checked in dojox/layout/tests/test_FloatingPane.html

comment:2 Changed 8 years ago by bill

You say that normally clicking anywhere on a FilteringSelect will open the drop down. I don't think so. See http://download.dojotoolkit.org/release-1.6.1/dojo-release-1.6.1/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.FilteringSelect for example. Can you give an example where clicking anywhere on the FilteringSelect opens it?

comment:3 in reply to:  2 Changed 8 years ago by Liubomir Armoutliev

Replying to bill:

You say that normally clicking anywhere on a FilteringSelect will open the drop down. I don't think so. See http://download.dojotoolkit.org/release-1.6.1/dojo-release-1.6.1/dijit/tests/form/_autoComplete.html?testWidget=dijit.form.FilteringSelect for example. Can you give an example where clicking anywhere on the FilteringSelect opens it?

Not anywhere on the FilteringSelect?, just on its _buttonNode, the button with an arrow in it. When the FilteringSelect? is in a FloatingPane?, you have to click exactly on the arrow or little below it.

comment:4 Changed 8 years ago by Liubomir Armoutliev

It's better observed when the FilteringSelect? is with bigger font-size in the style and respectively its _buttonNode is bigger

comment:5 Changed 8 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed

I'm not seeing the problem. Does this only happen on a specific browser or OS? I ran dojox/layout/tests/test_FloatingPane.html on FF3.6/WinXP and did ctrl+ until the floating pane titled "Remote Pane" stopping getting bigger, and then I clicked in the very bottom corner of the ComboBox? button node area and it opens the dropdown.

comment:6 in reply to:  5 Changed 8 years ago by Liubomir Armoutliev

Replying to doughays:

I'm not seeing the problem. Does this only happen on a specific browser or OS? I ran dojox/layout/tests/test_FloatingPane.html on FF3.6/WinXP and did ctrl+ until the floating pane titled "Remote Pane" stopping getting bigger, and then I clicked in the very bottom corner of the ComboBox? button node area and it opens the dropdown.

I can reproduce this problem on FF4.0.1/WinXP, Google Chrome 11.0.696.71/WinXP, Opera11.11/WinXP Try clicking more than once on the Combobox button

comment:7 Changed 8 years ago by Douglas Hays

Tried FF4/WinXP. Works there as well. Hopefully by "clicking more than once" you didn't mean double-clicking which is not supposed to open the dropdown.

comment:8 Changed 8 years ago by Liubomir Armoutliev

I do not mean double-clicking. I'm using dojo framework since version 0.4.0. This is absolutely strange. I have tested on several machines and the problem exists.

comment:9 Changed 8 years ago by Liubomir Armoutliev

Note the problem is observed only when in FloatingPane?

Note: See TracTickets for help on using tickets.