Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13154 closed defect (fixed)

Some Transition Animations Not Work on Android 2.2/2.3

Reported by: Ming Zhe Huang Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.6.1
Keywords: android Cc: Atsushi Ono
Blocked By: Blocking:

Description

Please use an Android Mobile Phone (2.2/2.3) to visit the test page: http://archive.dojotoolkit.org/nightly/checkout/dojox/mobile/tests/test_transition-animations2.html The following animations do not work.

Cover Cover (Reverse) Slide Vertical Slide Vertical (reverse) Cover Vertical Cover Vertical (reverse)

Attachments (1)

test_transition-animation3.html (12.4 KB) - added by Ming Zhe Huang 8 years ago.
Test case for deep component hierarchy

Download all attachments as: .zip

Change History (13)

comment:1 Changed 8 years ago by Chris Mitchell

Priority: normalhigh

comment:2 Changed 8 years ago by Chris Mitchell

Milestone: tbd1.7

comment:3 Changed 8 years ago by Chris Mitchell

hi kami, what's the latest status on this? we're getting close to beta2

comment:4 Changed 8 years ago by ykami

Cc: Atsushi Ono added
Keywords: android added

comment:5 Changed 8 years ago by Atsushi Ono

We have been working on this issue. The root cause of this issue appears to be that a transition animation and a scroll animation of ScrollableView? occur at the same time. We have reached a workaround on Android 2.3, although which does not work on Android 2.2. We do further investigation on Android 2.2.

comment:6 Changed 8 years ago by Atsushi Ono

We have also found a solution on Android 2.2. To dispatch mouse click events initiating transition animations in ScrollableView? with "setTimeout" function resolve this issue. We will commit it after regression tests.

comment:7 Changed 8 years ago by ykami

Resolution: fixed
Status: newclosed

(In [25539]) Fixes #13154 !strict Disabled unnecessary scrolling and added setTimeout to mouse event dispatching in scrollable#onTouchEnd

comment:8 Changed 8 years ago by Ming Zhe Huang

Resolution: fixed
Status: closedreopened

I tried the mobile gallery. Some transition effects do NOT 100% work in "Transitions" demo: Cover, Cover(reverse), Slide Vertical, Slide Vertical(reverse). Please see the attached test case. They sometimes fail. It seems that the problem is related to the deep component hierarchy.

Changed 8 years ago by Ming Zhe Huang

Test case for deep component hierarchy

comment:9 Changed 8 years ago by lee

flip still isnt working on android in beta 2 - see test_transition-animations2.html

comment:10 Changed 8 years ago by ykami

Yes, as far as I know, rotateY/rotateZ on webkit on android 2.2/2.3 are broken, thus animations that use rotateY/rotateZ (like flip) never work on such platforms. There's nothing we can do about it.

onoat, correct me if I am wrong.

comment:11 Changed 8 years ago by ykami

Resolution: fixed
Status: reopenedclosed

(In [25734]) Fixes #13154 !strict. View#performTransition changes display/visibility styles a couple of times, reducing of them seems to mitigate the problem. The problem apparently comes from android animation's instability, so there's no logical explanation here. The revealv animation was too fast. Adjusted its duration.

comment:12 Changed 8 years ago by ykami

In [26677]:

Refs #13154 !strict Fixed flip.css for better behavior on android devices.

Note: See TracTickets for help on using tickets.