Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13153 closed defect (fixed)

i18n.getLocalization is broken in a build

Reported by: ykami Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: Internationalization Version: 1.6.1
Keywords: Cc: Adam Peller
Blocked By: Blocking:

Description

i18n.getLocalization does not work if dojo/i18n.js is built.

In the funcion syncRequire, I found this comment:

// TODO: make sure closure compiler does not stomp on this function name
function define(bundle){
  __result= bundle;
}

I used shrinksafe, but unfortunately it mangles the function name, (i.e. "define" is renamed to something like "_28") and that is the cause of this problem.

Change History (4)

comment:1 Changed 8 years ago by Adam Peller

Cc: Adam Peller added
Owner: changed from Adam Peller to Rawld Gill

comment:2 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:3 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

(In [25350]) expresses critical code in i18n so that minifiers will not modify; fixes encoding with rhino; fixes #13153; !strict

comment:4 Changed 8 years ago by ykami

fix verified, thanks

Note: See TracTickets for help on using tickets.