Opened 8 years ago

Closed 8 years ago

#13151 closed defect (invalid)

The link created in dojo rich text is not working without http://

Reported by: hengly Owned by:
Priority: high Milestone: tbd
Component: Editor Version: 1.6.0
Keywords: dojo, editor, link Cc:
Blocked By: Blocking:

Description

steps: 1.visiting my local mail systems,open the dojo rich text editor

2.click on the create link button to create a link, enter www.yahoo.com as the URL and some text in the description

3.Sent to my self the email.

Expected: The link works fine.

Got: Check the link in the email, it shows http://mylocal/www.yahoo.com, which is not the correct URL.

Change History (1)

comment:1 Changed 8 years ago by Jared Jurkiewicz

Resolution: invalid
Status: newclosed

Bad input. The input field allows both relative and absolute urls. It has logic to try and determine which it is and append http:// if it can determine it is an absolute url.

The problem is www.whatever

Is not easily determinable to be relative or absolute. File paths can have .'s in them. File paths can start with www, so you can't readily assume that it is absolute and needs http://

so the link is inserted as-is (as you put it in). Without the http://, the browser then treats the URL as relative, and auto-appends http://<your server> to it when it is rendered.

If you're going explicitly to an external url, put http://, don't rely on the heuristics to try and append it for you. They do their best to figure it out, but there is no way to determine it perfectly.

Note: See TracTickets for help on using tickets.