Opened 8 years ago

Closed 6 years ago

#13146 closed enhancement (duplicate)

Tree: needed options for disable/enable the animation when expanding/collapsing nodes

Reported by: Sergey Kravchenko Owned by: bill
Priority: high Milestone: tbd
Component: Dijit Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

For large trees, the effects are not needed, but now it is hard-coded.

Change History (5)

comment:1 Changed 8 years ago by bill

The effects aren't needed for small trees either. Are you having a particular problem with large trees? One thing on my list is to consider is to replace all/most of the JS animations with CSS animations, which would make this easier to customize.

comment:2 Changed 8 years ago by Sergey Kravchenko

Client has asked me to remove the animation (he does not like animation). To this end, had to inherit dijit._TreeNode and clean animation. I decided my problem, though, if it were possible, it would be easier in future:

new dijit.Tree({
  animation: false
});

comment:3 Changed 8 years ago by bill

OK. Note that you can also set dijit.defaultDuration to 1, that should make it seem like there's no animation.

comment:4 Changed 8 years ago by Douglas Hays

Owner: set to bill

comment:5 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #14251.
This will be handled as part of the general changes to use CSS animations instead of javascript ones.

Note: See TracTickets for help on using tickets.