Opened 9 years ago

Closed 9 years ago

#13123 closed defect (worksforme)

Safari Tooltip test failures

Reported by: haysmark Owned by: bill
Priority: high Milestone: 1.7
Component: Dijit Version: 1.6.1
Keywords: dohfail Cc: Douglas Hays
Blocked By: Blocking:

Description

In Safari 5 on OS X 10.6 I get the following failures:

FAILED test: ../../dijit/tests/robot/Tooltip_a11y.html?port=9091&dohPlugins=doh/plugins/reportToRunner::dijit.Tooltip keyboard tests::hide on blur assertTrue('false') failed with hint: 
      		tooltip hidden
       2.5s
FAILED test: ../../dijit/tests/robot/Tooltip_a11y.html?port=9091&dohPlugins=doh/plugins/reportToRunner::dijit.Tooltip keyboard tests::show another tooltip assertEqual() failed:
      	expected
      		tooltip on a select
      	but got
      		tooltip for #1
      	lon
      
       with hint: 
      		tooltip text
       2.5s
FAILED test: ../../dijit/tests/robot/TooltipDialog_mouse.html?port=9091&dohPlugins=doh/plugins/reportToRunner::Select::close Select by clicking TooltipDialog assertTrue('false') failed with hint: 
      		Select Menu closed
       4.2s

Change History (5)

comment:1 Changed 9 years ago by Douglas Hays

Milestone: tbd1.7

The Tooltip_a11y problems are a dup fo #13125. I also see the TooltipDialog_mouse failure on my mac/safari env.

comment:2 Changed 9 years ago by bill

Keywords: dohfail added

add keyword to denote test failures in our automated tests

comment:3 Changed 9 years ago by Douglas Hays

Owner: set to bill

[25313] seems to have fixed the TooltipDialog_mouse failure "Select Menu closed" but caused a new failure to start showing up consistently, "expected changed, but got inline with hint: value changed to changed". This is being tested on mac/safari5.

comment:4 Changed 9 years ago by bill

Cc: Douglas Hays added

I just tried this twice (safari 5.0.5, mac) and it worked for me, is it still failing for you? I'm talking about running the test standalone.

comment:5 Changed 9 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed

I just ran Tooltip_a11y and Tooltip_mouse twice each and they're working now for me on the same machine that previously had failures. So it's either fixed or a timing problem.

Note: See TracTickets for help on using tickets.