Opened 8 years ago

Closed 7 years ago

#13118 closed defect (fixed)

simultaneous animations of overlay hide and view transition makes no animation effect

Reported by: zhangyp Owned by: ykami
Priority: high Milestone: 1.8
Component: DojoX Mobile Version: 1.6.1
Keywords: Cc: doughays@…, Atsushi Ono, Eric Durocher
Blocked By: Blocking:

Description

If simultaneous animations happen, it will create no effect on Android (not sure about iphone or BB).

The test calls the items on the overlay to start a view transition and hide the overlay itself. But there is no animation effects if both animations happened on same time.

In the test case, index.html address the problme and index2.html disable the overlay hide and make the view transition effects work.

Attachments (1)

overlay.zip (6.9 KB) - added by zhangyp 8 years ago.
test case

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by zhangyp

Attachment: overlay.zip added

test case

comment:1 Changed 8 years ago by Chris Mitchell

Priority: normalhigh

comment:2 Changed 8 years ago by Chris Mitchell

Milestone: tbd1.7

comment:3 Changed 8 years ago by ykami

Cc: Atsushi Ono added

comment:4 Changed 8 years ago by Chris Mitchell

Priority: highnormal

not blocker for 1.7rc1, lowering priority to normal

comment:5 Changed 8 years ago by Atsushi Ono

Zhangyp, could you confirm that you can still reproduce this issue?

I think the fix for transition animation on #13384 also works this issue, and I could not reproduce the issue with the latest code. This might be indirectly fixed.

comment:6 Changed 8 years ago by Atsushi Ono

I wrote a wrong ticket number. #13182 might indirectly fix this issue. Could you please confirm it, zyangyp?

comment:7 Changed 7 years ago by ykami

Cc: Eric Durocher added
Resolution: fixed
Status: newclosed

As far as we tested, the problem does not occur any longer. Please feel free to reopen this with detail information if you still see the problem.

Note: See TracTickets for help on using tickets.