Opened 9 years ago

Closed 8 years ago

#13117 closed defect (fixed)

mblAndroidWorkaround breaks input fields in nested views or scrollable views

Reported by: zhangyp Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.6.1
Keywords: android Cc: Atsushi Ono
Blocked By: Blocking:

Description

If there is any input fields in a nested view, the view cannot stop scrolling when the user selects an input field and types text into it. It happens on galaxy s and setting mblAndroidWorkaround to true is designed to work around the problem.

However, mblAndroidWorkaround:true breaks the nested views and on the contrary, mblAndroidWorkaround:false makes the function back to work. That means the work around breaks the input fields in nested view and not applying that work around make the nested views back to normal.

If we nest a scrollable view in a view, whether we set mblAndroidWorkaround to true or false does not help to solve the problem. The problem might be caused by leaving webkitTransform style on <body> or view's domNode.

The test case contains 3 html files. index.html shows nested views broken when mblAndroidWorkaround is true. index2.html shows nested views work when mblAndroidWorkaround is false. index3.html shows nested views broken when the nested one is scrollable view.

Attachments (1)

index.zip (2.0 KB) - added by zhangyp 9 years ago.
test case

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by zhangyp

Attachment: index.zip added

test case

comment:1 Changed 9 years ago by Chris Mitchell

Priority: normalhigh

comment:2 Changed 8 years ago by ykami

Cc: Atsushi Ono added
Keywords: android added

comment:3 Changed 8 years ago by ykami

Resolution: fixed
Status: newclosed

(In [25540]) Fixes #13117 !strict Disable touch scrolling capability and restore the browser's native scrolling when a virtual keyboard is shown.

comment:4 Changed 8 years ago by ykami

Resolution: fixed
Status: closedreopened

Received a report that the problem seemed to exist on HTC devices.

comment:5 Changed 8 years ago by ykami

Resolution: fixed
Status: reopenedclosed

(In [25631]) Fixes #13117 !strict. Adjust the scroll position in disableScroll()

Note: See TracTickets for help on using tickets.