Opened 8 years ago

Closed 8 years ago

#13102 closed enhancement (wontfix)

debugAtAllCosts nolonger forces xdomain.

Reported by: juxstar Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: Loader Version: 1.6.1
Keywords: debugAtAllCosts xdomain loader Cc:
Blocked By: Blocking:

Description

Therefore is is much harder for debuggers to enumerate .JS file. This helps visual studio integrated debugger set breakpoints. Also allows browser debuggers to list files using the "dojo.requires" to list javascript files. It is very inconvenient to not have this capability any more.

Change History (5)

comment:1 Changed 8 years ago by bill

Component: GeneralLoader
Owner: set to Rawld Gill
Priority: highnormal

You can get that behavior but just setting async:true (instead of debugAtAllCosts: true).

comment:2 Changed 8 years ago by Rawld Gill

Milestone: tbd1.7
Status: newassigned
Type: defectenhancement

comment:3 Changed 8 years ago by ben hockey

is this a duplicate of #12608 since it seems the ticket is related to 1.6.1 and *not* 1.7 development?

comment:4 Changed 8 years ago by juxstar

Is this only for 1.7? 1.6.1 does not have any mention djConfig.async or dojoConfig.async. I set this option in djConfig and it has no effect. I can only see the bootstrapper files in my list of scripts in my web debugger because all scripts were xhr and evaled. Please advise on a work around for 1.6.x Cheers

comment:5 Changed 8 years ago by Rawld Gill

Resolution: wontfix
Status: assignedclosed

debugAtAllCosts support has been dropped as of v1.6.

By far the best alternative is to convert the app to AMD and load with the loader in AMD mode by setting async to truthy. E.g.,

<script data-dojo-config="async:1", src="path/to/my/dojo.js"></script>

This causes all scripts to be loaded via script injection.

The second alternative it to do a build in 1.7, which converts the app to AMD. This is also a good start for converting the app to AMD permanently (usually, the best conversion will involve some design decisions). Note that the 1.7 builder can use node. If you build with the switches:

optimize=0 layerOptimize=0

You'll find the process quite fast.

The third alternative in IE is to get the MS script debugger or MS Visual Studio. Both allow you to set breakpoints in eval'd scripts. Visual Studio is better, but you may have to $buy$. An old version should be attainable for minimum $'s.

Note: See TracTickets for help on using tickets.