Opened 8 years ago

Closed 8 years ago

#13091 closed defect (invalid)

Problem in optimized build of Dojo with dijit.layout.BorderContainer

Reported by: tissandier Owned by: tissandier
Priority: high Milestone: 1.8
Component: General Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Adam Peller)

With the dojo revision r25213 there is a new problem with the build tool.

Running the example below in a non optimized dojo build works but breaks with an optimized build with error: GET http://127.0.0.1:8000/dojo-trunk/release/demosite/dijit.js 404 (Not Found)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
<title>Dojo Toolkit Test Page - BPM Sample</title>
<!-- load the dojo toolkit base -->

                <script type="text/javascript">
            var djConfig = { 
                parseOnLoad: true,
                                useGfxLayout: true
            }
        </script>
        <script type="text/javascript" src="../../dojo/dojo.js">
        </script>
        
                <script type="text/javascript" >
                        
        

dojo.require("dijit.layout.BorderContainer");

                
                </script>

     
<link rel="stylesheet" type="text/css" href="../../dijit/themes/tundra/tundra.css">



</head>
<body class="tundra">


<div dojoType="dijit.layout.BorderContainer"
                gutters="true" id="borderContainer"
                style="background: lightgray;">


</div><!-- Global Border Container -->
</body>
</html>

Change History (4)

comment:1 Changed 8 years ago by Chris Mitchell

Description: modified (diff)
Owner: set to Chris Mitchell

comment:2 Changed 8 years ago by Adam Peller

Description: modified (diff)

comment:3 Changed 8 years ago by cjolif

Owner: changed from Chris Mitchell to tissandier
Status: newpending

I don't reproduce in 1.8 (build system totally changed since 1.6.1), I guess we can close this Emmanuel?

comment:4 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.