Opened 8 years ago

Closed 8 years ago

#13073 closed defect (worksforme)

MenuItem: screen reading issue (Accessibility) . labels of ‘Menu Item’ is not readable via screen reading software (JAWS12).

Reported by: hemang999 Owned by:
Priority: high Milestone: tbd
Component: Dijit Version:
Keywords: a11y Cc: Becky Gibson
Blocked By: Blocking:

Description

Hi, Not reading menu-item-label by screen-reader users.(freedom scientific's JAWS v12)

I required to add

  • waiRole='presentation'/ role='presentation'dojo v 1.3/1.4/1.5/1.6

into dijit/templates/MenuItem.html to make it work.

<td class="dijitReset dijitMenuItemLabel" colspan="2" dojoAttachPoint="containerNode" waiRole="presentation"></td>

Sincerely,


Hemang Patel

Change History (4)

comment:1 Changed 8 years ago by Adam Peller

Cc: Becky Gibson added
Component: GeneralDijit
Keywords: bug removed

comment:2 Changed 8 years ago by bill

Summary: Screen reading issue (Accessibility) . labels of ‘Menu Item’ is not readable via screen reading software (JAWS12).MenuItem: screen reading issue (Accessibility) . labels of ‘Menu Item’ is not readable via screen reading software (JAWS12).

Thanks for the fix, but I want to confirm.... the template currently has role="menuitem", and it's been that way since at least version 1.5. (Note that waiRole is just being mapped to role.) According to http://www.w3.org/TR/wai-aria/roles#role_definitions menuitem is a valid role (and presumably the right role, since this is a menu item).

Becky, any input?

comment:3 Changed 8 years ago by Becky Gibson

Yes, the current role is correct. I recently looked into a similar issue and had no problems with JAWS 12 and Firefox 3.6.17 using the menu items and having them spoken. Can someone please provide an example and specifics of how to reproduce?

comment:4 Changed 8 years ago by bill

Resolution: worksforme
Status: newclosed

Closing ticket since no response, presumably the current behavior is correct.

Note: See TracTickets for help on using tickets.