Opened 8 years ago

Closed 8 years ago

#13028 closed enhancement (fixed)

enhance build tool to find AMD conversion errors

Reported by: Rawld Gill Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

Sometimes during conversion from dojo.provide/dojo.require to AMD define/require errors are made and some old loader calls are not converted. This results in a module not properly expressed in either format. Enhance the build app to find these errors.

Change History (4)

comment:1 Changed 8 years ago by tissandier

We have add similar problems with the build tools with dojo.provide/dojo.require that were located in comments. This was considered as real code by the build tool, resulting in many problems

comment:2 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:3 Changed 8 years ago by Rawld Gill

Milestone: 1.71.8

Regex processing has been improved; however, the real solution to the problem is parsing the resources which will not be done until v1.8 (at the earliest).

Please file "reasonable" conversion errors (as opposed to obvious bugs) to this ticket.

comment:4 Changed 8 years ago by Rawld Gill

Milestone: 1.81.7
Resolution: fixed
Status: assignedclosed

In [25768], several improvements have been made; see #13255. This problem is impossible to solve completely/correctly without a parser (which is planned for 1.8). Please file new tickets for any particular problems with the v1.7 build system.

Note: See TracTickets for help on using tickets.