Opened 8 years ago

Closed 8 years ago

#13009 closed defect (fixed)

builder missing version.js file

Reported by: rott Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildTools Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

SVN rev: 25068 Ubuntu linux 10.10 Java 1.6 rhino build

Upon running this command:

./build.sh profile=standard version=1.7.0 action=clean,release stripConsole=all layerOptimize=shrinksafe optimize=shrinksafe releaseDir=../../../ cssOptimize=comments releaseName=dojo_optimized copyTests=false

I get this error:

js: "../../dojo/dojo.js", line 805: exception from uncaught JavaScript? throw: JavaException?: java.net.MalformedURLException: no protocol: ../../util/build/version.js

I could not find the string "../../util/build/version.js" in any .js files, so perhaps it's hard coded in some java code? Or metadata?

Change History (7)

comment:1 Changed 8 years ago by Chris Mitchell

Owner: set to rawld

Hi Ralwld, looks like maybe a file was missed on checkin

comment:2 Changed 8 years ago by bill

Owner: changed from rawld to Rawld Gill

comment:3 Changed 8 years ago by Chris Mitchell

Summary: builder can't handle relative URLsbuilder missing version.js file

workaround: creating an empty file at util/build/version.js until file gets checked in

comment:4 Changed 8 years ago by bill

Component: GeneralBuildTools

comment:5 Changed 8 years ago by bill

Milestone: tbd1.7

comment:6 Changed 8 years ago by rott

Confirmed Chris's assertion. Creating an empty file at util/build/version.js gets my build working again.

comment:7 Changed 8 years ago by Chris Mitchell

Resolution: fixed
Status: newclosed

fixed in [25083]

Note: See TracTickets for help on using tickets.