Opened 13 years ago

Closed 13 years ago

#1300 closed defect (invalid)

sortable table selected Id issue

Reported by: h1ro Owned by: Tom Trenka
Priority: low Milestone: 0.9
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

if you have a sortable table and want to get the selected value, if that column is "id" rather than "Id" it returns no selected value. (so it's an upper case, lower case thing with the id)

Change History (3)

comment:1 Changed 13 years ago by dylan

Milestone: 0.5

comment:2 Changed 13 years ago by dylan

Owner: changed from bill to Tom Trenka

comment:3 Changed 13 years ago by Tom Trenka

Resolution: invalid
Status: newclosed

This is not a bug; if you want to change what field the table looks for in your JSON object as a key, you can change the valueField attribute:

<table dojoType="sortableTable" valueField="id" ...>

Note: See TracTickets for help on using tickets.