Opened 8 years ago

Closed 8 years ago

#12995 closed defect (fixed)

build does not inline dependency with "modules" in the name

Reported by: ben hockey Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

this is transferred from http://bugs.dojotoolkit.org/ticket/12673#comment:19

if i have the following structure, test.modules.foo is not included in the test/test.js output

test
  test.js
  bar.js
  modules
    foo.js

test.js

dojo.provide('test.test');

dojo.require('test.modules.foo');
dojo.require('test.bar');

is there something special with modules that is causing this?

profile:

dependencies = {
    action: "release",
    version: "1.7.0" + +new Date(),
    releaseName: "test",
    cssOptimize: "comments",
    optimize: "shrinksafe",
    layerOptimize: "shrinksafe",
    stripConsole: "normal",
    mini: true,
    layers: [
        {
            name: "../test/test.js"
        }
    ],
    prefixes: [
        ["test", "../test"]
    ]
};

Change History (3)

comment:1 Changed 8 years ago by ben hockey

fyi - i confirmed that it is indeed breaking because of the keyword modules. if i change to include dojo.mods.foo then the file is included in the build.

comment:2 Changed 8 years ago by ben hockey

Milestone: tbd1.7

comment:3 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: newclosed

(In [25165]) fixes bad regex that prevented including some dependencies with require|export|module in their id; fixes #12995; !strict

Note: See TracTickets for help on using tickets.