Opened 8 years ago

Closed 8 years ago

#12967 closed defect (wontfix)

mblAlwaysHideAddressBar does not work with fully async load on Android

Reported by: ykami Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.6.1
Keywords: 1.7-mobile Cc: Atsushi Ono
Blocked By: Blocking:

Description

We found that "mblAlwaysHideAddressBar" will not work after we enable fully async load on Android. More specific, it's Android 2.2, Moto Droid2. This can also be reproduced on Android 2.2 Samsung i9000.

Change History (7)

comment:1 Changed 8 years ago by ykami

(In [24977]) Refs #12967 !strict Increased the value of hideAddresBarWait

comment:2 Changed 8 years ago by ykami

Looks like it can happen even on iPhone.

comment:3 Changed 8 years ago by ykami

Resolution: fixed
Status: newclosed

comment:4 Changed 8 years ago by haysmark

Resolution: fixed
Status: closedreopened

mblAlwaysHideAddressBar still does not work for me on an Android 2.3 Droid X. For instance:

http://archive.dojotoolkit.org/nightly/checkout/dojox/mobile/tests/test_ScrollableMixin-custom.html

comment:5 Changed 8 years ago by ykami

Cc: Atsushi Ono added

comment:6 Changed 8 years ago by Atsushi Ono

mblAlwaysHideAddressBar does not work on some Android devices when overflow:hidden style is applied to html and body tags. This overflow:hidden style is used in some test cases including test_ScrollableMixin-custom.html for desktop browsers not to show scroll bar, but you can remove it for mobile browsers so that you can hide address bar. I tested it on HTC EVO and Nexus S, but I hope it will also work on Droid X.

comment:7 Changed 8 years ago by ykami

Resolution: wontfix
Status: reopenedclosed

Thanks, onoat, for the comment.

Note: See TracTickets for help on using tickets.