Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12947 closed defect (invalid)

Error popup shows too fast when insert URL begin with 'http://'

Reported by: hengly Owned by:
Priority: low Milestone: tbd
Component: Editor Version: 1.6.1
Keywords: dojo, editor, create link Cc: Douglas Hays
Blocked By: Blocking:

Description

1.Visit http://demos.dojotoolkit.org/demos/editor/

2.Clicking the 'Create Link'

3.Type the words http://www.aol.com

Expected: No error popup Actual: Error note displays when I type the word http://

Attachments (1)

error_popup.jpg (31.7 KB) - added by hengly 8 years ago.
Error popup

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by hengly

Attachment: error_popup.jpg added

Error popup

comment:1 Changed 8 years ago by Jared Jurkiewicz

Resolution: invalid
Status: newclosed

This isn't a bug. It's a validation input field and it is validating as you type. http:// isn't valid, it's incomplete, and is flagged as such. This is to ensure that you cannot set invalid values, as invalid fields directly control the state of the insert button.

Working as designed.

comment:2 Changed 8 years ago by bill

Cc: Douglas Hays added

Doug, shouldn't the partially completed regex code be kicking into effect here, so it doesn't flag prematurely?

comment:3 Changed 8 years ago by Douglas Hays

The LinkDialog? plugin is doing its own regexp validation and causing the warning popup. The ValidationTextBox? kept its default regexp=.* since it was never specified. If the partial regexp code is working properly, then the template should have been specified instead as:

input dojoType='dijit.form.ValidationTextBox' required='true' regExp='${urlRegExp}'

I suspect that the urlRegExp is incomplete and doesn't include the mailto protocol and thus the builtin partial regexp code won't work until this is also fixed in the plugin.

Note: See TracTickets for help on using tickets.