Opened 8 years ago

Closed 7 years ago

#12940 closed defect (fixed)

dojo.dnd.Moveable creates extra movers when used with delay

Reported by: Gombo Owned by: Eugene Lazutkin
Priority: high Milestone: 1.7
Component: DnD Version: 1.6.1
Keywords: dojo.dnd.Moveable, delay, mover Cc:
Blocked By: Blocking:

Description

When using dojo.dnd.Moveable or any of its descendants with non-zero "delay" parameter two mover objects would be created when drag is initiated. May be even more if there were several attempts are blocked by delay (two per attempt).

The reason is that onMouseDown function pushes four events to this.event (two of them "ontouchmove" and "ontouchend" are apparently recent additions), but when onMouseMove calls onMouseUp only two are popped. As a result onMouseMove get called once more.

To fix: change number of iterations of the loop in onMouseUp function to four.

Sorry, I don't know how to make proper diff and I'm thoroughly confused by CLA stuff - could someone please submit this trivial patch?

Change History (2)

comment:1 Changed 7 years ago by Eugene Lazutkin

My understanding is that the problem is related to touch events, not mouse events, right?

comment:2 Changed 7 years ago by bill

Milestone: tbd1.7
Resolution: fixed
Status: newclosed

Fixed in 1.7, see #13135.

Note: See TracTickets for help on using tickets.