Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#12897 closed defect (fixed)

mobileMvc demo broken due to TransitionEvent changes (mobile/ViewController)

Reported by: Chris Mitchell Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

demos/mobileMvc/demo.html

click any link.

dojox/mobile/ViewController:63 Uncaught ReferenceError?: url is not defined

Trying to get url from the event, but not there.

Change History (8)

comment:1 Changed 9 years ago by bill

Component: GeneralDojoX Mobile

comment:2 Changed 9 years ago by Chris Mitchell

r24796 has partial fix for this, but still gettin the following error during event dispatch: TypeError?: Cannot read property 'dispatchEvent' of undefined.

This is occurring on tests when transitioning to a view loaded from remote view content is using url.

Have to head home now, will try debugging further later, unless u beat me to it.

comment:3 Changed 9 years ago by Chris Mitchell

See dojox/mobile/tests/test_transition-to-dynamic-view.html for a non-demos testcase that reproduces the problem.

comment:4 Changed 9 years ago by Chris Mitchell

Owner: changed from Dustin Machi to ykami

With this latest revision, ViewController? now gets to the _instantiate function() when running test_transition-to-dynamic-view.
However, I can't see how this test was working before dmachi's TransitionEvent? changes, because: the items.json file it's referencing is in the old ItemFileReadStore? JSON data format, having a top level object, with "items:" array of child objects. The _instantiate function is looking for what appears to be jsonSchema formatted data or something similar...raw JSON with type information as properties. Is it possible that the json file format should have been changed to a new format a while ago, and this testcase was broken?

reassigning to ykami for more background info on the file format for dynamic views...

comment:5 Changed 9 years ago by ykami

(In [24828]) refs #12897 fixed script error on ff \!strict

comment:6 Changed 9 years ago by ykami

(In [24900]) refs #12897 another bug introduced by the view transition refactoring \!strict

comment:7 Changed 9 years ago by ykami

Resolution: fixed
Status: newclosed

I think it's already been fixed.

comment:8 Changed 8 years ago by ykami

(In [25757]) refs #12897 !strict Recovered the implementation of urlTarget that was broken due to the transition refactoring

Note: See TracTickets for help on using tickets.