Opened 9 years ago

Closed 9 years ago

#12883 closed enhancement (wontfix)

Use Same CSS Padding on TestBox and TextArea in Tundra

Reported by: Fergus Hadley Owned by: Douglas Hays
Priority: high Milestone: future
Component: Dijit - Form Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

Currently on the textArea widget has this applied:

.tundra .dijitTextArea {
    padding: 3px;
}

This means that you cannot easily apply a single width to all dijits, because the textarea need the width with the padding subtracted.

Change History (2)

comment:1 Changed 9 years ago by bill

Component: DijitDijit - Form
Owner: set to Douglas Hays

comment:2 Changed 9 years ago by Douglas Hays

Milestone: tbdfuture
Resolution: wontfix
Status: newclosed

The problem is more box sizing model and less about CSS. The TextBox? widget templates were designed to emulate padding-box. The HTML textarea form control uses border-box. Dojo could either set the box-sizing for TextArea? to padding-box (which is not in the w3c spec and does nto work on IE6/7), or dojo could change the TextArea? widget to have additional wrapper DOM nodes and thus emulate padding-box (which will slow down rendering due to additional DOM tree size). Both of these alternatives would cause backward compatibility issues. I'm marking this as wontfix due to these issues. The best alternative would be for the web page authors to set box-sizing to padding-box (using browser specific notation like -moz-box-sizing: padding-box).

Note: See TracTickets for help on using tickets.