Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#12881 closed defect (fixed)

EDG - left/right/up/down keys results in lost foucs during editing

Reported by: evan Owned by: evan
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.6.1
Keywords: Cc:
Blocked By: Blocking:

Description

Steps to reproduce with the attached test case

  1. Double click a row for editing
  2. Use arrow keys for navigating

The focus is lost, it should actually be remained in the input for editing

Attachments (1)

12881.html (3.9 KB) - added by evan 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by evan

Attachment: 12881.html added

comment:1 Changed 9 years ago by evan

Resolution: fixed
Status: newclosed

(In [24708]) Fixes #12881 by ignore navigating with arrow keys during editing state.

comment:2 Changed 9 years ago by evan

(In [24786]) Refs #12881 !strict, fixes a regression of [24708] - cell content is sometimes emptied during switch editing state.

comment:3 Changed 8 years ago by evan

(In [25130]) Refs #12881 !strict use a more safe way, also remove edit.restore in _View.renderRow()since it's doing nothing actually.

comment:4 Changed 8 years ago by evan

(In [25163]) Refs #12881 !strict backport to 1.6 branch

Note: See TracTickets for help on using tickets.